Moodle4.0は、UI(見た目)が大きく変わり、絵文字が多用されるようになりました。
↓このような感じです↓

ただ、データベースの言語を絵文字対応できるようにしておかないと、言語パックを編集しようとするとエラーが発生します。

※言語パックの編集、言語カスタマイゼーションは、Moodle内の言葉を自分好みに変更するときに利用します。

そのため、Moodle4.01をインストールする前に、データベースの文字コードをutf8_mb4にする必要があります。
(ここではphpMyadminを利用しています。)

  1. phpMyadminにログイン
  2. 操作をクリック
  1. 照合順序をutf8_mb4_general_ci にする
  1. Moodleをインストールする

これで言語パックをカスタマイズできるようになります。

Follow me!